졸업작품을 진행하던 도중 노트북으로 스프링 프로젝트를 열었는데 mysql 오류가 발생하였다.
access denied for user 'root'@'localhost' (using password: yes)
패스워드와 관련된 문제라고 하는데 지금까지 잘 동작하던 패스워드가 갑자기 문제라고 하니 당황스러웠다.
구글링을 해본 결과 비밀번호를 변경해주면 해결할 수 있다고 해서 블로그를 따라 변경해주려고 하니, cmd에서 하는 건지 우분투에서 하는 건지 잘 모르겠어서 그냥 MySQL Workbench 에서 바꿔주기로 했다.
우선 MySQL Workbench을 실행시킨다.

이후 아무 connection으로 들어간다

왼쪽에 Schemas와 Administration이 있는데 Administration로 이동한다

Administration에서 Users and Privileges로 이동

root (변경하려고 하는 페스워드의 이름)을 선택하고 패스워드를 변경한다

이후 스프링 프로젝트에서 변경된 페스워드를 입력하고 실행하니 오류가 해결되었다.